Cloud Console Deployment Errors

Incident Report for Elastic Cloud (Public)

Resolved

This incident has been resolved
Posted Jul 15, 2026 - 01:12 UTC

Monitoring

The ability to manage Elastic Cloud Hosted deployments via the Cloud Console has been restored
Posted Jul 15, 2026 - 00:31 UTC

Investigating

We are investigating errors with our cloud console affecting access to create, update, delete and view Elastic Cloud Hosted deployments. Our team is actively investigating the cause so that they can mitigate and restore the service.
Posted Jul 15, 2026 - 00:15 UTC
This incident affected: Global services (Cloud console).