Disruption to instance memory and disk usage on cloud.elastic.co for 7.x customers

Incident Report for ESS (Public)

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 15:09 UTC

Monitoring

We have deployed a fix for this issue and are monitoring to verify 7.x Elasticsearch deployments are properly reporting memory and disk usage both on cloud.elastic.co and via the deployments API.
Posted Apr 17, 2025 - 00:57 UTC

Identified

We've identified the issue and have begun deploying the fix into several regions. We anticipate to resolve the issue in the remaining regions within the next hour.
Posted Apr 16, 2025 - 20:28 UTC

Investigating

We've determined that some customers running 7.x Elasticsearch deployments may have issues seeing Instance memory and disk usage on cloud.elastic.co and through the deployments API. We're continuing to investigate the issue.
Posted Apr 16, 2025 - 18:00 UTC