Performance metrics delays in Azure WestEurope
Incident Report for ESS (Public)
Resolved
We've addressed the cause of delays and Performance metrics properly updating.

Billing Usage information was discovered to also be delayed during this window, but are updating properly now as well.
Posted Sep 22, 2024 - 18:44 UTC
Investigating
We are investigating delays with the Performance metrics in Cloud UI for deployments in Azure WestEurope. This is not impacting the deployments themselves.
Posted Sep 22, 2024 - 17:22 UTC
This incident affected: Azure Netherlands (azure-westeurope) (Deployment metrics: Azure azure-westeurope).