Known issue with APM Data Ingestion v8.15.0
Incident Report for ESS (Public)
Resolved
We have implemented restrictions in Elastic Cloud blocking the problematic upgrade paths. The small number of impacted customers have been notified via an email containing information on the mitigation steps to follow. These steps are also documented in:

https://www.elastic.co/guide/en/observability/8.15/apm-known-issues.html#_upgrading_to_v8_15_x_may_cause_ingestion_to_fail

https://www.elastic.co/guide/en/observability/8.15/apm-known-issues.html#_upgrading_to_v8_15_0_may_cause_apm_indices_to_lose_their_lifecycle_policy
Posted Oct 31, 2024 - 23:46 UTC
Update
There is a known issue where upgrading to v8.15.0 may cause APM indices to lose their lifecycle policy. It is suggested to upgrade to at least v8.15.1.

Please see this article for more detail and support on how to navigate your upgrades:
https://www.elastic.co/guide/en/observability/8.15/apm-known-issues.html#_upgrading_to_v8_15_0_may_cause_apm_indices_to_lose_their_lifecycle_policy


There is a known issue where upgrading from v8.12.2 or below directly to any 8.15 version causes APM data ingestion to be rejected. It is suggested to first upgrade to v8.14.3 and from there upgrade to version 8.15.1 or higher.
Please see this article for more detail and support on how to navigate your upgrades:
https://www.elastic.co/guide/en/observability/8.15/apm-known-issues.html#_upgrading_to_v8_15_x_may_cause_ingestion_to_fail
Posted Oct 31, 2024 - 15:32 UTC
Identified
There is a known issue where upgrading to v8.15.0 may cause APM indices to lose their lifecycle policy. It is suggested to upgrade to at least v8.15.1.

Please see this article for more detail and support on how to navigate your upgrades:
https://www.elastic.co/guide/en/observability/8.15/apm-known-issues.html#_upgrading_to_v8_15_0_may_cause_apm_indices_to_lose_their_lifecycle_policy

There is a known issue where upgrading from v8.12.2 or below directly to any 8.15 version causes APM data ingestion to be rejected. It is suggested to first upgrade to v8.14.3 and from there upgrade to version 8.15.1 or higher.
Posted Oct 31, 2024 - 14:04 UTC
This incident affected: Global services (APM connectivity: Global).