Issues with Email Alerts

Incident Report for Elastic Cloud (Public)

Resolved

This issue is now resolved. Email delivery has been successful with no monitored issues.
Posted May 09, 2026 - 01:01 UTC

Monitoring

A solution has been implemented, and email delivery has resumed. We are continuing to track the situation closely and will provide another update once considered resolved.
Posted May 08, 2026 - 23:11 UTC

Investigating

We are currently investigating reports that some customers may be facing issues with email alerts.
Posted May 08, 2026 - 18:10 UTC