Cloud MFA emails may be delayed

Incident Report for ESS (Public)

Resolved

Our service has fully recovered from the upstream SendGrid outage.
Posted Apr 24, 2025 - 00:59 UTC

Monitoring

We've observed that our platform's MFA email reliability has improved. We are continuing to monitor the status of our MFA provider and SendGrid for updates.

https://status.sendgrid.com/incidents/6fj45kvpw8n3
Posted Apr 23, 2025 - 22:24 UTC

Investigating

Elastic is currently aware of delivery delays for MFA emails while logging into https://cloud.elastic.co.

We have identified the issue as an upstream outage of Sendgrid, which is used by our MFA provider to send emails - https://status.sendgrid.com/

We are currently monitoring the situation and will provide an update within 1 hour.
Posted Apr 23, 2025 - 22:00 UTC