Delays in Billing Usage
Incident Report for ESS (Public)
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 03:45 UTC
Monitoring
We've addressed the delays and Billing Usage is updating again. We'll monitor for 1h and resolve if no new issues.
Posted Sep 24, 2024 - 02:43 UTC
Investigating
We're investigating delays in Billing Usage in the Cloud UI.
Posted Sep 24, 2024 - 01:25 UTC
This incident affected: Global services (Cloud console).