The root cause has been identified and addressed. We are currently monitoring the system to ensure stability and performance.
Posted Apr 17, 2025 - 08:59 UTC
Update
We have determined that some customers on Elastic Cloud Serverless may see incorrect anomaly counts on anomaly detection jobs and some detection rules using filters may not be working correctly. We have also determined that time shifts in lens may be incorrect.
Additionally, if you are using Elasticsearch directly and are using a filters aggregation, have a top level query, but have not turned on the "other_bucket", your results may be incorrect.
We have identified a fix for the issue and are validating the change before deploying to Elastic Cloud Serverless.
Posted Apr 16, 2025 - 20:47 UTC
Investigating
We have determined that some customers on Elastic Cloud Serverless may see incorrect anomaly counts on anomaly detection jobs and some detection rules using filters may not be working correctly. We are continuing to investigate the issue.