slow loading times on the elastic.co webpage

Incident Report for ESS (Public)

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 13:19 UTC

Monitoring

We have implemented a fix to mitigate the problems with website latency on www.elastic.co
Metrics indicate that the performance has improved, and returned to expected levels.

Monitoring will continue.
Posted Apr 24, 2025 - 11:22 UTC

Update

We are continuing to investigate some alerts and reports of latency on our www.elastic.co website.
Some users may experience a delay with the page loading.

We will provide an update within 1 hour
Posted Apr 24, 2025 - 10:52 UTC

Investigating

We are aware that some users may experience slow loading times on the elastic.co webpage. Our engineers are currently investigating, and will provide an update within 1 hour
Posted Apr 24, 2025 - 10:07 UTC
This incident affected: Global services (Elastic website - elastic.co).