We are aware of an issue that caused some credit card customers to receive a "Past Due Invoice" email for their April 1 invoice, despite a successful payment. This email was sent in error and does not indicate that successfully paid invoices will be charged again. We have identified the root cause and are working with a vendor to understand options to prevent its recurrence. We apologize for the inconvenience.
Posted May 02, 2025 - 20:04 UTC
Identified
We are aware of an issue that caused some credit card customers to receive a "Past Due Invoice" email for their May 1 invoice, despite a successful payment. This email was sent in error and does not indicate that successfully paid invoices will be charged again. We have identified the root cause and are working with a vendor to understand options to prevent its recurrence. We apologize for the inconvenience.
Posted May 02, 2025 - 09:16 UTC
This incident affected: Global Services - Serverless (Email Notifications) and Global services (Email notifications).