Issue when creating Serverless projects in Azure eastus region

Incident Report for Elastic Cloud (Public)

Resolved

Azure's storage component issues in the eastus region have been resolved. Consequently, Serverless project creation times have returned to normal and are functioning as expected.
Posted Aug 20, 2026 - 16:22 UTC

Monitoring

We have determined that the issue stems from an upstream problem with Azure's storage component. Upon examination, the impact is limited strictly to new project initialization times, resulting in longer creation times for Serverless projects in the Azure eastus region.

We will provide a further update once the issue has been resolved.
Posted Aug 20, 2026 - 14:05 UTC

Investigating

An issue affecting the creation of new Serverless projects in Azure's eastus region has been identified. Our team is actively investigating to determine the root cause.

We will provide a follow-up status update within the next hour or as soon as the root cause is established, whichever occurs first.
Posted Aug 20, 2026 - 12:48 UTC
This incident affected: Elastic Cloud Serverless.