Credit card customers receiving incorrect past due invoice emails

Incident Report for ESS (Public)

Resolved

We are aware of an issue that caused some credit card customers to receive a "Past Due Invoice" email for their April 1 invoice, despite a successful payment. This email was sent in error and does not indicate that successfully paid invoices will be charged again. We have identified the root cause and are working with a vendor to understand options to prevent its recurrence. We apologize for the inconvenience.
Posted Apr 02, 2025 - 22:17 UTC

Investigating

We are currently investigating reports that some credit card customers incorrectly received "Past Due Invoice" emails . We are working to identify the root cause and will provide updates as soon as more information is available.
Posted Apr 02, 2025 - 13:20 UTC