Azure degradation impacting some services

Incident Report for ESS (Public)

Resolved

We are currently investigating an issue with Azure impacting some of our services, specifically Managed OTLP and MIS.
Posted Oct 30, 2025 - 01:19 UTC

Investigating

We are currently investigating an issue with Azure impacting some of our services, specifically Managed OTLP and MIS.
Posted Oct 29, 2025 - 16:59 UTC