Increased Latency in Deployment APIs

Incident Report for ESS (Public)

Resolved

We have seen no further uptick in response rate latency, therefore we are calling this incident resolved.
Posted Jun 26, 2025 - 22:45 UTC

Monitoring

The impact to customers is now resolved and we've seen a stabilization in response rates. We will continue to monitor this for a few hours.
Posted Jun 26, 2025 - 20:57 UTC

Investigating

We are investigating some response rate slowdowns in our Deployments API. Impact is limited to the AWS us-east-1 region and to managing deployments, not access to existing ES clusters. We will update the status again in 1 hour.
Posted Jun 26, 2025 - 19:41 UTC
This incident affected: AWS N. Virginia (us-east-1) (Deployment orchestration (Create/Edit/Restart/Delete): AWS us-east-1).