The connectivity issues affecting a subset of customers in our AWS EU West (Paris) region have been resolved. Failed probes recovered at 11:36 UTC following remediation of an issue with our underlying cloud infrastructure provider. We are no longer observing any elevated error rates or latency in the region. We apologise for any inconvenience caused and will conduct a post-incident review.
Posted Apr 27, 2026 - 12:40 UTC
Monitoring
Our monitoring system reports that AWS EU West 3 (Paris) region ingress layer traffic has recovered to normal levels as of 11:36 UTC and our SLO alerts have resolved. We are continuing to monitor and will update once we are confident the issue is fully resolved.
Posted Apr 27, 2026 - 12:08 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 27, 2026 - 11:57 UTC
Identified
We are currently investigating connectivity issues affecting a subset of customers in our AWS EU West 3 (Paris) region. Some requests may be experiencing elevated latency or failures. Our team is actively investigating, and we are working with our cloud infrastructure provider on the underlying issue. Other regions are not affected at this time. We will provide updates as the situation develops.