Deployment metrics display issues in GCP us-central1

Incident Report for ESS (Public)

Resolved

The issue has been fully resolved.
Posted Oct 22, 2025 - 12:11 UTC

Monitoring

The issue has been resolved and a backlog of metrics is being processed which should clear in the next hour.
Posted Oct 22, 2025 - 11:35 UTC

Investigating

We are aware of issues impacting the display of deployment metrics in Elastic Cloud Hosted GCP us-central1 region, we are working to resolve this
Posted Oct 22, 2025 - 09:46 UTC
This incident affected: GCP Iowa (us-central1) (APM connectivity: GCP us-central1).