Upstream Azure Outage Causing Service Degradation

Incident Report for Elastic Cloud (Public)

Update

We continue to monitor the situation which has mostly recovered. A small number of deployments are still not healthy.
Our support team is working on resolving these on a case-by-case basis.
Posted May 30, 2026 - 06:36 UTC

Monitoring

Remediation is underway and systems are recovering. We  continue to monitor the situation and will post an update in the next 2 hours or earlier.
Posted May 29, 2026 - 18:50 UTC

Update

We continue to remediate the impact of an upstream Azure outage in Azure West US 2 (azure-westus2), limited to availability zone westus2-2.

Customers with deployments not configured for high availability in this region may continue to experience intermittent connectivity errors, degraded performance, or delays when performing deployment operations.

Deployments configured for high availability across multiple availability zones are not expected to be affected.

Our teams remain actively engaged with Microsoft Azure and are working to restore affected infrastructure. We will provide further updates as recovery progresses
Posted May 29, 2026 - 14:26 UTC

Update

We continue to respond to an upstream Microsoft Azure outage in Azure West US 2 (azure-westus2), caused by a datacenter power event reported by Azure. Elastic impact remains limited to availability zone westus2-2.

Customers with deployments not configured for high availability in this region may continue to experience intermittent connectivity errors, degraded performance, or delays when performing deployment operations (including create, edit, restart, and delete).

Deployments configured for high availability across multiple availability zones are not expected to be affected.

Our teams are actively remediating affected infrastructure in the impacted zone. Recovery progress is currently constrained by degraded Azure platform APIs and capacity availability in the region.
Posted May 29, 2026 - 11:46 UTC

Identified

We are continuing to investigate the impact of an upstream Azure WestUS2 outage which is impacting Elastic services and deployment healthiness, including Elastic Serverless projects hosted in this region.

We have confirmed that impact to our service is limited to a single availability zone (westus2-2). Customers whose deployments are not configured for high availability may experience intermittent errors, delays, or inability to access certain features.

Deployments configured for high availability across multiple zones are not expected to be affected.

Our team is working to mitigate the situation and the impact on our environment. We will provide further updates as more information becomes available.
Posted May 29, 2026 - 10:43 UTC

Update

We are continuing to investigate this issue.
Posted May 29, 2026 - 06:50 UTC

Update

We are continuing to investigate this issue.
Posted May 29, 2026 - 06:35 UTC

Investigating

We are continuing to investigate the impact of an upstream Azure WestUS2 outage which is impacting Elastic services and deployment healthiness, including Elastic Serverless projects hosted in this region.

We have confirmed that impact to our service is limited to a single availability zone (westus2-2). Customers whose deployments are not configured for high availability may experience intermittent errors, delays, or inability to access certain features.

Deployments configured for high availability across multiple zones are not expected to be affected.

Our team is working to mitigate the situation and the impact on our environment. We will provide further updates as more information becomes available.
Posted May 29, 2026 - 06:32 UTC