Organisation Owner role access to Elastic Cloud Hosted Kibana

Incident Report for Elastic Cloud (Public)

Update

Update: This incident is still ongoing and we are continuing to investigate.
Posted Sep 10, 2026 - 06:03 UTC

Identified

We have identified and are in the process of fixing+mitigating a bug in our permissions management UI that is prevents users with the Organisation Owner role and Cloud Console, Elasticsearch, and Kibana access from accessing Kibana in Hosted Deployments.
Posted Sep 10, 2026 - 01:30 UTC