Timeout issues in billing apis and pages

Incident Report for ESS (Public)

Resolved

The incident has been resolved.
Posted Jul 18, 2023 - 15:46 UTC

Monitoring

We believe the situation has been resolved at this time and are monitoring. We will post another update in an hour.
Posted Jul 18, 2023 - 14:47 UTC

Investigating

We are aware of an issue causing timeouts in our billing APIs and pages. We are investigating and will provide an update in an hour.
Posted Jul 18, 2023 - 13:50 UTC
This incident affected: Global services (Cloud console).