Customers Unable to Create BYOK Deployments in Azure

Incident Report for ESS (Public)

Resolved

The fix has been rolled out to all regions and customers should now be able to create BYOK deployments again.
Posted Jun 05, 2025 - 20:11 UTC

Identified

We have identified the issue and have a fix in place for the first region. We are working to propagate the fix to the rest of the Azure regions. Once all regions have been addressed we will post a final update.
Posted Jun 05, 2025 - 19:51 UTC

Investigating

The Elastic Cloud Hosted service is experiencing issues with the creation of new BYOK (bring-your-own-key) deployments in Azure regions. This only affects users attempting to create a new BYOK deployment in Azure regions. Existing Azure BYOK and non-BYOK deployments are not impacted. The team is working on identifying the root case.
Posted Jun 05, 2025 - 18:11 UTC