Prices are not being displayed when creating new deployments

Incident Report for Elastic Cloud (Public)

Resolved

This incident has been resolved.
Posted Jul 19, 2018 - 21:04 UTC

Monitoring

A fix has been deployed.
Posted Jul 19, 2018 - 20:57 UTC

Identified

The issue has been identified and we're working on a fix. This does not impact deployment creation.
Posted Jul 19, 2018 - 19:31 UTC