Billing history page loading issues
Incident Report for ESS (Public)
Resolved
The fix has been applied. The issue has been resolved.
Posted Mar 01, 2022 - 20:31 UTC
Update
We are still working on a fix.
We will post an update in two hours.
Posted Mar 01, 2022 - 19:24 UTC
Update
We are still working on a fix.
We will post an update in two hours.
Posted Mar 01, 2022 - 17:11 UTC
Update
We are still working on a fix.
We will post an update in two hours.
Posted Mar 01, 2022 - 15:12 UTC
Identified
We have identified the issue which prevents our Billing History page to load.
We are working on fixing it. We apologize for the inconvenience.
We will post an update in an hour.
Posted Mar 01, 2022 - 14:23 UTC
This incident affected: Global services (Cloud console).