We can confirm no connectivity or latency issues in the last 60 minutes. We consider this resolved.
Posted Nov 12, 2025 - 17:34 UTC
Update
We recently investigated intermittent network latency in the AWS us-east-1 region, which may have briefly caused connection timeouts for some Serverless projects and Elastic Cloud Hosted deployments. Our monitoring indicates that service health has returned to normal. We are continuing to actively monitor the situation to ensure continued stability. Expect next update in 60 mins or as soon as we have any updates to share.
Posted Nov 12, 2025 - 16:49 UTC
Monitoring
We recently detected intermittent network latency in the AWS us-east-1 region, which may have briefly caused connection timeouts for some Serverless projects. Our monitoring indicates that service health has returned to normal. We are continuing to actively monitor the situation to ensure continued stability. Expect next update in 60 mins or as soon as we have any updates to share.
Posted Nov 12, 2025 - 16:44 UTC
This incident affected: AWS N. Virginia (us-east-1) (Elasticsearch connectivity: AWS us-east-1, Kibana connectivity: AWS us-east-1) and Elastic Cloud Serverless.