Loading Issues for Deployments

Incident Report for ESS (Public)

Resolved

Issue has been resolved, systems are operational.
Posted May 28, 2025 - 11:55 UTC

Monitoring

The fix has been deployed, we keep monitoring the situation.
Posted May 28, 2025 - 10:15 UTC

Identified

Some customers deployments edit page on the Elastic Cloud Console are currently stuck in a loading state. The root cause has been identified, and the team is working on a solution
Posted May 27, 2025 - 22:42 UTC