Privatelink hostnames reported by API are incorrect

Incident Report for Elastic Cloud (Public)

Resolved

We have successfully deployed a fix for the PrivateLink hostname issue to the User Console. Customers who experienced incorrect PrivateLink URLs or connectivity issues with their deployments should now see correct hostnames. We apologize for the inconvenience.
Posted Apr 10, 2026 - 19:54 UTC

Update

We are still working on moving the fix to production as we experienced some testing issues.
Posted Apr 10, 2026 - 12:18 UTC

Update

We have merged a fix and are working on deploying it to production
Posted Apr 09, 2026 - 22:44 UTC

Identified

A recent change to our Privatelink implementation resulted in the URLs reported by the deployment API being incorrect in some cases, causing connectivity issues for customers who relied on those URLs. We have identified the issue and are working on a fix.
Posted Apr 09, 2026 - 20:46 UTC