Errors pulling 8.15.4 and 8.16.0 packages
Incident Report for ESS (Public)
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 06:56 UTC
Monitoring
The 8.16.0 packages are now available in https://artifacts.elastic.co/packages/8.x
Posted Nov 13, 2024 - 06:51 UTC
Update
8.16.0 is still unavailable in https://artifacts.elastic.co/packages/8.x. As a workaround, it can be downloaded from https://www.elastic.co/downloads/.

We will provide an update once it is available on https://artifacts.elastic.co/packages/8.x
Posted Nov 12, 2024 - 22:25 UTC
Identified
We've fixed a corrupted manifest. Elastic Cloud is no longer impacted and fully functional. Adding https://artifacts.elastic.co/packages/8.x and pulling 8.15.4 packages is also working.

Pulling 8.16.0 packages are still impacted and being worked on. An update will be provided in 1 hour, or less if the situation changes.
Posted Nov 12, 2024 - 21:36 UTC
Update
We've identified that 8.15.4 packages are also impacted. If you have already added https://artifacts.elastic.co/packages/8.x/apt you can still pull packages other than 8.16.0 or 8.15.4, however attempts to add this as a new repository will fail.

We're continuing to work on a resolution. An update will be provided in 1 hour, or less if the situation changes.
Posted Nov 12, 2024 - 20:11 UTC
Investigating
We are investigating errors when pulling 8.16.0 apt packages from artifacts.elastic.co. This also impacts Elastic Cloud customers.
Posted Nov 12, 2024 - 19:23 UTC
This incident affected: Global services (Deployment orchestration (Create/Edit/Restart/Delete), Elastic Downloads).