Intermittent 404s when accessing elastic.co webpage

Incident Report for Elastic Cloud (Public)

Resolved

404 errors have been resolved on the elastic.co webpage.
Posted Feb 25, 2026 - 14:38 UTC

Investigating

We currently investigating an issue causing intermittent 404 errors when visiting the elastic.co webpage. We will provide additional updates as they become available.
Posted Feb 25, 2026 - 14:33 UTC
This incident affected: Global services (Elastic website - elastic.co).