Delay in deployment creation in AWS us-east-1

Incident Report for ESS (Public)

Resolved

This issue has been resolved.
Posted Oct 22, 2025 - 12:44 UTC

Monitoring

This issue has been mitigated and new Deployments are coming up as expected. We are continuing to monitor.
Posted Oct 22, 2025 - 12:05 UTC

Investigating

We are experiencing an issue with new Deployments taking longer than expected to create in AWS us-east-1. We'll post an update on this within the hour
Posted Oct 22, 2025 - 11:22 UTC
This incident affected: AWS N. Virginia (us-east-1) (APM connectivity: AWS us-east-1).