Replication bug causing slow recoveries

Incident Report for Elastic Cloud (Public)

Identified

We have identified the root cause and the team is working on a fix scheduled to be released in Elasticsearch version 9.5.3

What you can do:
- If you have not yet upgraded to 9.5.*, you are not affected as upgrades to 9.5 have been disabled until 9.5.3 is released
- If you are already running 9.5 and experience the symptoms of this issue, please contact Elastic Support.

More information can be found on https://www.elastic.co/docs/release-notes/elasticsearch/known-issues#elasticsearch-9.5.2-known-issues
Posted Sep 01, 2026 - 11:07 UTC

Investigating

We are aware of a bug affecting customers on Elasticsearch versions 9.5.0, 9.5.1 and 9.5.2 where bulk index operations processed on the primary shard can result in divergence on the replicas resulting in high disk usage and long-running recoveries. The team is working on a fix. More information can be found on https://www.elastic.co/docs/release-notes/elasticsearch/known-issues#elasticsearch-9.5.2-known-issues

The next update will be in the next 2 hours or sooner if needed.
Posted Sep 01, 2026 - 08:16 UTC
This incident affects: Elastic Cloud Hosted.