Internal Monitoring Data Delay

Incident Report for Elastic Cloud (Public)

Identified

We have identified the issue and implemented a fix.  We are seeing signs of system recovery and are continuing to monitor the situation closely.
Posted Jul 01, 2026 - 16:50 UTC

Investigating

We're experiencing a monitoring data delay affecting a limited number of Azure regions. Elastic Cloud's internal metrics for these regions are being ingested more slowly than usual.
What you may notice: Deployment metrics and instance utilization data may not appear in the Elastic Cloud UI for Hosted Deployments and Serverless Projects in affected regions.
What's not affected: Your deployments and projects are running normally. Data ingestion and all functionality remain unimpacted besides lacking some monitoring data on the Elastic Cloud UI.

We're actively investigating the root cause and will provide an update within the next 2 hours.
Posted Jul 01, 2026 - 15:39 UTC
This incident affects: Azure Virginia (azure-eastus2) (Deployment orchestration (Create/Edit/Restart/Delete): Azure azure-eastus2), Azure Washington (azure-westus2) (Deployment orchestration (Create/Edit/Restart/Delete): Azure azure-westus2), and Azure Virginia (azure-eastus) (Deployment orchestration (Create/Edit/Restart/Delete): Azure azure-eastus).