We can confirm that the applied fixes are fully working and we are now resolving this incident.
Posted May 16, 2024 - 13:32 UTC
Update
We continue monitoring the situation, but we can confirm that the fix is working as intended and we are no longer showing duplicated deployments in the cloud UI.
Posted May 16, 2024 - 10:48 UTC
Monitoring
We have implemented the required fix so that no duplicated deployments should be shown anymore in the Cloud UI. We continue monitoring the situation and will provide an update within the next hour.
Posted May 16, 2024 - 07:54 UTC
Identified
Our engineers are working on fixing an issue where some customers see duplicate deployments in their admin console. We can confirm at this time that deployments are not duplicated and the issue is isolated to the display of the resources in the Cloud UI. There is no impact on the billing for the duplicated projects.
Posted May 16, 2024 - 07:25 UTC
This incident affected: Global services (Cloud console).