Email delays impacting some customers

Incident Report for Elastic Cloud (Public)

Resolved

Our teams have resolved an issue with the mail system, which caused delays for emails being sent for customers such as password reset requests, receiving billing invoices and adding users to organisations.
Posted Dec 17, 2025 - 12:49 UTC

Identified

We're aware of delays affecting emails being sent for customers, such as password reset requests, receiving billing invoices and adding users to organisations. Our team is investigating the issue and we will provide updates on our progress.
Posted Dec 17, 2025 - 12:10 UTC