Issue with capture and display of deployment metrics in AWS eu-west-1

Incident Report for ESS (Public)

Resolved

We have completed our work to restore deployment metrics in AWS eu-west-1 and the service is back to normal.
Posted May 19, 2025 - 12:05 UTC

Monitoring

We have applied a fix to restore the display of deployment metrics in AWS eu-west-1 and the service is recovering. We will continue monitoring for further impact and provide an update in one hour, or sooner if there is a change in status.
Posted May 19, 2025 - 10:33 UTC

Investigating

We are investigating a potential service impact with the capture and display of deployment metrics. Our team is actively investigating the cause so that they can mitigate and restore the service. We believe customers in AWS eu-west-1 may be affected. We will post an update in one hour, or sooner if there is a change in status.
Posted May 19, 2025 - 09:52 UTC
This incident affected: AWS Ireland (eu-west-1) (Deployment metrics: AWS eu-west-1).