Issue with AWS Marketplace Sign Up Process

Incident Report for ESS (Public)

Resolved

The issue with Elastic AWS Marketplace integration has cleared.
Posted Mar 10, 2025 - 20:38 UTC

Monitoring

AWS Marketplace Sign Ups are now unblocked. We're continuing to monitor the AWS Marketplace service health.
Posted Mar 10, 2025 - 18:41 UTC

Investigating

We are currently investigating an issue on our AWS Marketplace product page which is blocking new customers sign ups.
Posted Mar 10, 2025 - 17:38 UTC
This incident affected: Global services (AWS Marketplace).