Cloud API and user console intermittent failure
Incident Report for ESS (Public)
Resolved
All services are operational, the incident is resolved.
Customers experienced failures accessing their Elastic Cloud user console and Elastic Cloud API between 13:09 UTC and 13:18 UTC.
Availability of Elastic Cloud deployments was not impacted.
Our engineers are working on a root cause analysis. Our preliminary assessment is that an intermittent issue with our Apache ZooKeeper coordination layer that affected connections from our backend API services was the main contributing factor to this incident.
Posted Mar 12, 2021 - 15:30 UTC
Monitoring
Customers experienced failures accessing their Elastic Cloud user console and Elastic Cloud API between 13:09 UTC and 13:18 UTC.
Availability of Elastic Cloud deployments was not impacted.
All services are operational and we are monitoring them closely.
Posted Mar 12, 2021 - 14:38 UTC
Identified
We have identified that the cause of the experienced API failures was due to a set of intermittent connection failures to our internal coordination layer from our API backend services.
Elastic Cloud user console and Elastic Cloud API have recovered since 13:18 UTC, and all services are operational.
Availability of Elastic Cloud deployments was not impacted.
Next update in 30 minutes.
Posted Mar 12, 2021 - 14:02 UTC
Investigating
We are investigating intermittent failures.
Customers accessing their Elastic Cloud user console and Elastic Cloud API experienced intermittent errors between 13:10 UTC and 13:25 UTC.
Availability of Elastic Cloud deployments is not impacted.
Next update in 30 minutes.
Posted Mar 12, 2021 - 13:27 UTC
This incident affected: Global services (Cloud console).