Elastic Cloud Hosted deployment creation/modify delays in AWS eu-central...

Incident Report for ESS (Public)

Resolved

The incident is resolved.
Posted Aug 27, 2025 - 18:39 UTC

Monitoring

We've validated that any delay in new deployment creation and existing deployment change activity has been resolved. We will continue to monitor.
Posted Aug 27, 2025 - 18:14 UTC

Investigating

Some Elastic Cloud Hosted customers may be observing delays with new deployment creation and existing deployment changes in AWS eu-central-1 and ap-southeast-1 regions. We will post another status update within 30 minutes or as new information becomes available.
Posted Aug 27, 2025 - 17:44 UTC