Trial users unable to leave organization to join existing organization

Incident Report for ESS (Public)

Resolved

A fix for the issue has been implemented. Users should be able to leave a trial and join another organization without issue.
Posted Mar 14, 2025 - 17:55 UTC

Update

We are still working on rolling out the fix. Next update will be in four hours, or sooner if new information is available.
Posted Mar 14, 2025 - 14:57 UTC

Identified

We are still working on rolling out the fix. Next update will be in four hours, or sooner if new information is available.
Posted Mar 14, 2025 - 11:09 UTC

Update

We have identified the cause of the issue and we are working on a fix. Next update will be in four hours, or sooner if new information is available.
Posted Mar 14, 2025 - 05:06 UTC

Investigating

We're investigating an issue facing new users when they sign up for a trial, but are unable to leave that organization without creating a deployment or project. This leads to billable usage, which blocks the user from being able to leave that trial to join another organization.
Posted Mar 14, 2025 - 03:22 UTC
This incident affected: Global services (Cloud console).