Issues delivering static assets to products

Incident Report for Elastic Cloud (Public)

Resolved

This issue has been resolved.
Posted Jun 29, 2026 - 16:58 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 29, 2026 - 16:33 UTC

Identified

We have identified an issue with our ability to deliver certain static assets to our products. We have identified and are working to implement a fix.
Posted Jun 29, 2026 - 16:32 UTC