BYOK deployment creation errors in GCP

Incident Report for ESS (Public)

Resolved

A fix for this issue has been deployed and it is again possible to create BYOK (Bring-your-own-KEy) deployments in our GCP regions
Posted Oct 10, 2025 - 22:45 UTC

Identified

We have identified the issue preventing creation of deployments in GCP regions using BYOK (Bring-your-own-Key), and we are currently working on deploying a fix.
Posted Oct 10, 2025 - 16:18 UTC

Investigating

BYOK Deployment creation in GCP regions is not currently possible, existing deployments are not impacted. The team is working on a mitigation path.
Posted Oct 10, 2025 - 10:45 UTC