Issues provisioning new Elastic Cloud Hosted capacity in Azure regions

Incident Report for Elastic Cloud (Public)

Resolved

This issue is now resolved.
Posted Feb 18, 2026 - 19:12 UTC

Investigating

We are currently aware of and investigating an issue causing failure to provision new capacity in Elastic Cloud Hosted Azure regions. We will provide additional updates as they become available.
Posted Feb 18, 2026 - 17:56 UTC
This incident affected: Elastic Cloud Hosted.