Issues with creating/updating Deployments in several regions

Incident Report for Elastic Cloud (Public)

Resolved

This issue has been resolved.
Posted Jun 17, 2026 - 17:35 UTC

Monitoring

We have identified and deployed a fix for this issue and are continuing to closely monitor the situation.
Posted Jun 17, 2026 - 16:53 UTC

Identified

We are currently investigating an issue when creating/updating Deployments in several regions.

We've identified the issue and working on applying a fix.

We will provide an update when one is available or within the hour, whichever comes first.
Posted Jun 17, 2026 - 15:52 UTC
This incident affected: Azure Virginia (azure-eastus2) (Deployment orchestration (Create/Edit/Restart/Delete): Azure azure-eastus2), GCP Netherlands (europe-west4) (Deployment orchestration (Create/Edit/Restart/Delete): GCP europe-west4), AWS Ohio (us-east-2) (Deployment orchestration (Create/Edit/Restart/Delete): AWS us-east-2), AWS N. California (us-west-1) (Deployment orchestration (Create/Edit/Restart/Delete): AWS us-west-1), AWS London (eu-west-2) (Deployment orchestration (Create/Edit/Restart/Delete): AWS eu-west-2), AWS Frankfurt (eu-central-1) (Deployment orchestration (Create/Edit/Restart/Delete): AWS eu-central-1), and Azure johannesburg (azure-southafricanorth) (Deployment orchestration (Create/Edit/Restart/Delete): Azure azure-southafricanorth).