Operational emails not being delivered to customers
Incident Report for ESS (Public)
Resolved
This incident has been resolved.
Posted Jul 11, 2024 - 13:39 UTC
Investigating
Operational emails were not delivered to customers between 21:15pm UTC and 22:26pm UTC. The issue was identified and resolved.
Posted Jul 10, 2024 - 22:56 UTC