Issues with upgrading to Elasticsearch 8.13.0
Incident Report for ESS (Public)
Resolved
A fix for this issue has been committed and will be included in the upcoming Elasticsearch 8.13.1 release. The Elasticsearch 8.13.1 release is planned to be available mid next week.
At that time, we will make Elasticsearch 8.13 available again for Elastic Cloud customers.

We are resolving this incident at this time as we have confirmed no Elastic Cloud customers are affected by the Elasticsearch 8.13.0 issue.
If you believe you are affected or have any questions related to this incident, please open a support case at https://support.elastic.co.
Posted Mar 29, 2024 - 15:40 UTC
Monitoring
A fix for this issue has been implemented and is scheduled to be released with Elasticsearch 8.13.1. The exact release timeline of 8.13.1 is currently being defined.

On Elastic Cloud, version 8.13.0 will remain unavailable. As soon as version 8.13.1 is released, this version will become available to all Elastic Cloud customers, offering them a safe upgrade path to Elasticsearch 8.13.

We continue to monitor the situation and will provide an update until today 17:30 UTC, or sooner if there is a change in status.
Posted Mar 29, 2024 - 12:32 UTC
Identified
The issue has been identified and our teams are working on a fix for Elasticsearch.
No Elastic Cloud deployment was affected by this bug and upgrades to version 8.13.0 are prevented.

Our next update will be at 17:30 UTC, or sooner if there is a change in status.
Posted Mar 29, 2024 - 05:15 UTC
Investigating
We have identified a critical bug in Elasticsearch 8.13.0. The bug causes all clusters running 8.10+ which are using downsampling or have used downsampling since upgrading to 8.10 or later to fail to upgrade to 8.13.0. The nodes on version 8.13.0 will be unable to join the cluster.

As an immediate mitigation action we are preventing upgrades on Elastic Cloud to version 8.13.0.

Our next update will be in one hour, or sooner if there is a change in status.
Posted Mar 28, 2024 - 17:30 UTC
This incident affected: Global services (Deployment orchestration (Create/Edit/Restart/Delete)).