Azure network outage in South Central US
Incident Report for ESS (Public)
Resolved
Azure confirmed that they have entirely resolved the outage. We have resolved all the infrastructure issues caused by the upstream Azure outage.
Posted Dec 27, 2024 - 17:44 UTC
Monitoring
We have resolved all of the infrastructure issues caused by the upstream Azure outage. However, we will leave the incident open in Monitoring status until Azure confirms they have completely resolved the outage. Azure is posting regular updates on its public status page here: https://azure.status.microsoft/en-us/status.

We will post the next update when new information is available.
Posted Dec 27, 2024 - 05:25 UTC
Update
We continue to see periodic infrastructure issues as a result of the ongoing Azure incident. Azure is posting regular updates on its public status page as it works to resolve the problem: https://azure.status.microsoft/en-us/status.

We have mitigated the significant majority of the impact for our customers but will keep our incident open until the upstream issue is fully resolved. Elastic Cloud deployments configured for HA continue to be available. Non-HA deployments may be impacted. Due to our inability to reliably provision new infrastructure in this zone, it is possible that attempts to scale up or create new deployments will not succeed.

We will continue to monitor and mitigate the impact on our customers as best we can while we wait for Azure to address the root cause. We will post an update in the next four hours or sooner if new information is available.
Posted Dec 27, 2024 - 04:37 UTC
Update
We continue to see periodic infrastructure issues as a result of the ongoing Azure incident. We have mitigated the significant majority of the impact for our customers. Elastic Cloud deployments configured for HA continue to be available. Non-HA deployments may be impacted until Azure resolves the upstream issue. Azure is indicating that it may be several hours before the incident is fully resolved.

We will continue to monitor and mitigate the impact to our customers as best we can while we wait for Azure to address the root cause. We will post an update in the next four hours, or sooner if new information is available.
Posted Dec 27, 2024 - 00:57 UTC
Update
We are continuing to work to remediate the infrastructure impacted by the Azure outage. We will provide an update in one hour, or sooner if we have additional information to share.
Posted Dec 26, 2024 - 23:57 UTC
Update
Azure has mitigated the incident on their end. We are continuing to work to restore the health of a small number of impacted deployments in the region. We will provide an update in one hour, or sooner if we have additional information to share.
Posted Dec 26, 2024 - 22:51 UTC
Update
Azure has mitigated the incident on their end. We are now working to restore the health of any impacted deployments in the region. We will provide an update in one hour, or sooner if we have additional information to share.
Posted Dec 26, 2024 - 21:46 UTC
Identified
Azure is working to mitigate the outage impacting zone 2 of the South Central US region. Elastic Cloud deployments configured for HA continue to be available. Non-HA deployments may be impacted until Azure resolves the upstream issue. We will provide updates as soon as we have them.
Posted Dec 26, 2024 - 20:46 UTC
Investigating
Azure is experiencing a network-related outage in zone 2 of the South Central US region. As a result, non-HA Elastic Cloud deployments running in that zone may be unavailable. Deployments in the South Central US that are configured for HA remain available at this time. Azure is working on mitigating the incident. We will continue to monitor and provide updates as we have them.
Posted Dec 26, 2024 - 19:47 UTC
This incident affected: Azure Texas (azure-southcentralus) (Elasticsearch connectivity: Azure azure-southcentralus).